What's new

Cannot Add Filter to a Smart Object...Help Appreciated!


acroreef

Member
Messages
17
Likes
4
I am using Photoshop 22.4.2. I converted a photo to a smart object. (The mode is 8 bit). I tried to then add a filter to the image but nothing happens. (I tried to add a "paint daubs" filter to the image: Filter/Artistic/Paint Daubs/enter or OK). Nothing happened, the filter was NOT added to the smart object image. I have looked elsewhere online but nothing seems to be an obvious fix.

Any assistance is greatly appreciated. Thank you!

-Dave
 

IamSam

Administrator
Staff member
Administrator
Messages
19,407
Likes
12,001
Hey Dave. I followed your example and it worked for me, so I can't replicate your results. What type of resets have you tried?
 

thebestcpu

Guru
Messages
2,004
Likes
1,835
Another possibility would be that another Layer was active (not the Smart Object) or that on your Smart Object Layer, you have one of the masks selected or the Filter Mask selected.
Hard to know yet a screenshot might really help as well.
John Wheeler
 

acroreef

Member
Messages
17
Likes
4
Thank you both for your response. I didn't have any masks on the layer and the layer was selected. Very strange...The filter never made it to the layer. I'll try to produce a couple of screen shots and post them. Thanks again.

-Dave
 

JeffK

Guru
Messages
1,070
Likes
1,248
One other thought - is the layer you're working on locked? It would be an icon to the right:

1625452522855.png
 

acroreef

Member
Messages
17
Likes
4
I did think of that, but no, the layer was not locked. For some reason, the filter I am selecting is not making it to the layer.
 

JeffK

Guru
Messages
1,070
Likes
1,248
You refer only to Filter/Artistic/Paint Daubs. Have you tried other filters on the smart object layer?
Did you just update? Did you have a similar problem with the previous version? What was your previous version?
Are you in RGB mode?
If you provide us screen shots, please provide the full document window including the document info at the lower left of the screen:

1625455252633.png
 

thebestcpu

Guru
Messages
2,004
Likes
1,835
Here is another way the filters will not show. If the "Groups" are collapses the added effects and filters are also collapsed I believe. Do you have the indicator shown in the image where you can click the dropdown arrow.
With groups collapsed I can add Smart Filters and they will be added yet will not show until you click the drop down arrow.
Again screenshots will help from lots of guessing :)
John Wheeler

Filters-and-Effect-not-showing.jpg
 

acroreef

Member
Messages
17
Likes
4
I will try to post screen shots tomorrow. I am using RGB color mode. None of the filters will work from the filter gallery with a smart object layer. However, when I do use a filter from outside the "filter gallery," such as "blur," "gaussian blur," it works as intended. I also tried another version of Photoshop, same problem.
 

acroreef

Member
Messages
17
Likes
4
Folks, I think I got it to work! There is something that was hidden from view. This is what I noticed: After clicking on filter, filter gallery, then choosing a gallery, (artistic), then choosing the filter (paint daubs), there is a box below the adjustments. At the top, in the box, is the filter selected. I didn't see the "EYE" icon that must be checked to activate the filter! (If it isn't checked, one doesn't know it is there).

I think that solved the mystery. Thanks again for all of the help from this esteemed group!

-Dave
 

IamSam

Administrator
Staff member
Administrator
Messages
19,407
Likes
12,001
Yes, this is a way to apply multiple filters to the same image in filter gallery. With each filter added, the "eye" is turned on by default. You have to turn them off by clicking.

EDIT: I have to correct myself (from a now deleted statement), with a new image just converted to a Smart Object, filter added from filter gallery, you can turn the "eye" off and the filter will not be applied. So this was indeed the problem!

What I was doing was trying to turn the filter off by clicking the "eye" off AFTER I had already applied the filter..........like an edit. In doing so, the filter reverted back to it's original setting and automatically turned the "eye" back on. I also discovered that if you apply more than one filter, and you turn one off, it still remains in the panel until it's deleted.

Screen Shot 2021-07-05 at 12.27.41 AM.png

I just assumed that you had not turned the filter layers off so this was not even a consideration for me.

Glad you figured it out.
 

Top