What's new

How to save 3 channels images into single channel


mfran2002

New Member
Messages
3
Likes
0
hello everybody,
I'm a beginner about photography but I have to solve an issue urgently.

I have 4 multispectral cameras (GREEN, RED, BLU-NIR and RGB) that all return to me 3 channels images (actually jpg).
Ok for RGB camera, but concerning the other ones (GREEN, RED, BLU-NIR) I need single channel images.

So I need to convert/save them: may you please explain me how can I do using Photoshop?

More: I have hundreds images to convert...:eek:...
I'm a computer technician so I'm asking if it is possible to write (using Photoshop) and run a script to perform this activity. It would be a greater help form me

THANKS TO EVERYONE THAT CAN HELP ME
 
Last edited:

thebestcpu

Guru
Messages
2,167
Likes
2,048
Hi mfran

Here are the steps to take each of the three color channels and save then out as there own untagged grayscale file.

- Read the RGB file
- In the Channels Palette dropdown, select Split Channels (this step will create 3 separate grayscale files open in photoshop)
- Then Use File > Automate > Batch and use the option to choose all open files to for saving and all other parameters not to do any other actions

You can create a Photoshop Action to do the above steps.

Those are the basics without any details yet hope that gets you going.

John Wheeler
 

mfran2002

New Member
Messages
3
Likes
0
Hello and thanks thebestcpu,
I've tried your suggestion with "File > Automate > Batch" utility

I selected the option "all open files" for saving and I left all other parameters by default

but I receive this error (I translate from italian):

Error: The command "Fade" is not currently available. (-25920)

what's my mistake?
:rolleyes:
 
Last edited:

thebestcpu

Guru
Messages
2,167
Likes
2,048
Sorry mfran2002, I am not notified when there has been a response and missed it for the last couple of days.

I had forgotten that with the Batch command there was not an option to use no Action and so I am sure the error was probably because the action that was being used, was not compatible with the image in some fashion.

You would either need to create an Action that does nothing and use that in the Batch command or more simply use the File > Scripts > Image Processor command. With this later command you can select to use all open files and also make sure to uncheck the box near the end of the dialog box about running an Action.

Hope this helps.
 

Top