What's new

New lens


hershy314

Guru
Messages
1,616
Likes
769
I finally got a new lens for my camera, got myself a SIGMA 70-210MM F/4-5.6 UC LENS FOR CANON EF MOUNT. The price was pretty good which is why I got it. But now I'm having trouble. I was told this lens would work with my camera, a Canon EOS Rebel XTi, but when I try to take a photo it tells me Err99 Shooting is not possible. Turn the power switch of to <off> and <on> again or re-install the battery. Did I get the wrong lens? What can I do to fix this problem?
 

Tom Mann

Guru
Messages
7,223
Likes
4,341
Hi Hershy - I'm not a Canon guy, and don't have the time to look this up at the moment, but on Nikon systems of that generation, an error like that will occur if the aperture ring on the lens is not set to its smallest value, eg, f/16 or f/22.

HTH,

Tom M
 

hershy314

Guru
Messages
1,616
Likes
769
I contacted the place I got the lens from and they told me this lens was for a film camera and not a digital one and that's why it wont work. So I'm back to no lens again, though I have gotten this to work a few times.
 

Tom Mann

Guru
Messages
7,223
Likes
4,341
Hershy, it's a bit odd that the seller would state that this EF lens is only for film cameras, but it's good they are taking back that lens.

I say this because a quick search turned up many articles that state that your Rebel XTi is supposed to handle EF lenses with only rare compatibility problems.
http://learn.usa.canon.com/app/pdfs/quickguides/CDLC_EF_Lenses_QuickGuide.pdf
https://en.wikipedia.org/wiki/Canon_EF_lens_mount

Apparently, the occasional incompatibility occurs mostly with older third party (ie, non-Canon) lenses, so maybe you ran into one of these situations.

Best,

Tom M
 

Top