What's new

Text disappears when editing it.

#1
Out of the blue... I started to experience disappearing text when editing same text. Googling the "Disappearing Text" phenomena show its a very frequent problem, but the solutions are oftentimes font specific or confusing at best. So I'm running CS6 v.13.0.x64 on a 2-month old Mac 27" with 40 Gigs of memory, running Mojave v10.14.5. Here's what's happening:

I'm designing a business card using a graphic logo I developed for a friend. Started laying out the card, dragged over the logo I created, centered it, then tried to add his name. Worked OK I thought, but when I went to add a phone number on the opposite side of the card I started typing and the number started appearing but it was the wrong font for a phone number, so I backspaced, changed the font, and started typing... nothing appears? The cursor indicated that it was moving with each letter, but it was blank. Even tried duplicating the name, and moving it, then editing to change the name to numbers... the text all disappeared in the duplicate layer. So after trying a restart, a reset, I also tried a "New" graphic. Made a 5" X 5" square, used color fill to change its color, then added a text line and it showed up... so I backspaced and all text on that layer comes up as transparent.

What I can't figure is that I'm using fonts I used before with no issues, everything was fine, in fact, the fonts I used yesterday was where I started and now it seems like regardless of which font I use, they go transparent the minute I try to edit in any way. I've used PS for years, never had a problem like this.
 

Top