What's new

Silverfast Ai 8.8 Plugin problem


brian_mk

Member
Messages
8
Likes
0
Does anyone use the Silverfast Ai 8.8 plugin with Photoshop CC?

If I use it to carry out normal scan using 'Import from Silverfast', it works fine.
However if I simply quit the Silverfast application (without scanning) and then try to exit Photoshop, Photoshop reports an unhandled exception message:-
"Could not complete your request because of a program error".
Once this happens, the only way to exit Photoshop is to kill the process from Task Manager.
I'm guessing this is probably some sort of file permission or memory access problem.
The problem happens in several versions of PS CC I have tried including 21.2.4, 22.1.1 and the latest 22.3.1
However, it does not happen if I go right back to PS CC 2017.
BTW, I have tried disabling GPU support in PS just in case - it made no difference.

Can someone try reproducing this to confirm the problem?
 

brian_mk

Member
Messages
8
Likes
0
After some research, it looks like the Silverfast Ai 8.8 Photoshop Plugin is not fully compatible with later versions of Photoshop CC.
Later versions of PS CC require Silverfast Ai 9.
Lasersoft want around £130 for the upgrade to Silverfast Ai 9.
This seems a lot to pay just to fix the problem with the plugin.
As I don't use my scanner much these days, I'm not really interested in the other changes between versions 8 and 9.

It looks like my options are:-
1) Use Silverfast Ai 8.8 stand-alone for scanning.
2) Use the older PS CC 2017 with the Ai 8.8 Plugin.
3) Use the later versions of PS CC and avoid quitting Silverfast without first carrying out a scan.
 

Top