What's new

Type tool won't work Help

Lynny

Well-Known Member
#1
Our Text Tool has stopped working,
Here's what happens....

click on the type tool,
choose Arial (or any font)
click on the canvas
a new type layer is added in the layer manager
but there's no blinking curser
type anyway
the words show in the layer manager
but not on document
Swear and curse a lot
Save file
Open in other computer
PS says other computer doesn't have font, and put's error triangles on type layers in layer manager.....

Can however edit previously typed text.....

What we have tried to fix it,
1. Reinstalled PS over itself,
2. Restored system to a time when we knew it worked
3. Deleted a few font's (thought we had to many)

Text works OK in other programmes, so it's not a computer problem....

We would prefer not uninstalling PS and reinstalling, finding and installing all those filters again arghhhh

But need PS Text tool working today....

Any other suggestions?????......

Lynny :( :( :( :( :(

Using PS7 OS XP Pro
 
#2
Lynne, try moving the Preferences file out of its current folder...just drag it to the desktop. Make sure Photoshop isn't launched. When you're done, relaunch Photoshop; it'll build a new preferences file. See if that works. If it doesn't, you still have your original file.

Location of the file for WinXP: Documents and Settings\[user profile]\Application Data\Adobe\Photoshop\7.0\Adobe Photoshop 7.0 Settings
 

Lynny

Well-Known Member
#3
Thank you we have tried that during the day, at one stage during the day, it started working, but hates us again now...

Lynn
 
#4
Lynny, only thing I can tell you is what you don't want to hear...uninstall and do a fresh install. As for plug-ins, any custom brushes, shapes, gradients, etc....before you uninstall move those out of the PS folder...just move the entire plug-in folder, and others that you know you have custom stuff in so you'll have them; just drag them onto the new PS folder.

BUT, before you do that, launch the fresh new Photoshop and see if the type tool works. If you have a lot of 3rd party plugins, drag them, half at a time, and retest. Then drag half of the remaining in, retest, until you have all of them. If you hit a spot where the tool no longer works, you'll know that one of those plug-ins is the culprit.

I know it's a PITA and takes time, but if there IS a problem with a plugin, you'll be able to see it instantly. If the preference file didn't do the trick, that's the only thing I know to do.
 
#5
:( Oooh... sorry to hear this Lynny! Looks like you have no option but to go the PITA route that A-C has suggested.
Julie, great trouble-shooting on your part!

[confused] My son got frustrated the other day and came to me to tell me that the "type tool" wasn't working. It turned out that it was, indeed, working, but the PPI of his open document was set to "1"... hence, he couldn't see the type. Although it's obviously not your problem, I relate this story for other new users to PS who might run across this very same incident. ;)
 

Lynny

Well-Known Member
#7
yes, any new document or document that doesn't have a type layer already on it...... we have it fixed for the moment, we opened a document that had a lot of text layers on it, and did what we had to do for a job on that......editing the text was fine...... changing size, type and font, background etc.

Opened a new document and the text tool worked..... would still like to hear from anyone that has had the problem..... or maybe this is the techiquical way to fix it..... :)

Lynny
 
#8
Glad you got it to work, Lynny! Interesting....I've never come across this particular problem before. I have had some tool or other suddenly stop working correctly (but not failing completely). In that case, moving the prefs file usually does the trick. Maybe PS just had to "reset" itself?
 
#9
hi i am having the same problem as Lenny....I have windows and i have already uninstalled and reinstalled the program..... it worked for one picture and decided to not work again...the text shows up on the layers but not on the picture... and the curser is still not showinf up... where do i go from here??
 
#10
Same for me

I believe I had the same problem as you but I just fixed it so lets hope it also works for you. First type some text and as it is still in the progress, press 'ctrl' + T', it should open a things with two tabs, 'Paragraph' and 'character'. Go through both tabs and make all the values above 0 and not something insane like a decimal... tell me if it works!
 
Last edited:
#11
I believe I had the same problem as you but I just fixed it so lets hope it also works for you. First type some text and as it is still in the progress, press 'ctrl' + T', it should open a things with two tabs, 'Paragraph' and 'character'. Go through both tabs and make all the values above 0 and not something insane like a decimal... tell me if it works!
i had the same problem.
no need to uninstall and reinstall. i did that, doesn't work

so i came here and fallowed kitten484's suggestion. and it worked :D

i pressedd ctrl+t... and saw font size "--214568786;("...i don't what was that so i changed it to like 38...as kitten484 saidd above 0. and made new text layer. it worked fine in there. so i just deleted the previous text layer. worked on the new layer.

to test it, i closed the photoshop and opened it again. opened as new layer and typed. it worked.
 

Top