What's new
Photoshop Gurus Forum

Welcome to Photoshop Gurus forum. Register a free account today to become a member! It's completely free. Once signed in, you'll enjoy an ad-free experience and be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

Spin Blur Filter


Well-Known Member
I'm trying to use the Spin Blur tool to add some radial blur to the wheels of a stationary vehicle. I basically understand how the tool works, but I am not able get the center of the blur tool to be in the center of the blur. Every time I open the tool the center (or bullseye) is off center with the adjustable circle. I've tried everything I can think of including a few tutorials. All they tell you is how to perform the spin blur process, but not how to change it or set it up. It's probably something simple but I can't seem to figure it out. I included a sample of what I'm getting.

Any help is appreciated.


Photoshop 2015.5.1
MBP Retina, 15 inch, Mid-2015


  • Screen Shot 2016-08-28 at 5.12.47 PM.png
    Screen Shot 2016-08-28 at 5.12.47 PM.png
    3.7 MB · Views: 1
In Windows and using PS CC 2015.5.1 you can HOLD ALT + Drag the center point.

MrToM and IamSam, thank you both very much for your suggestions! Unfortunately neither corrected my problem. I am attaching three images which are the following:

Image 1. This is on my desktop iMac using the same Photoshop version as my MBP. The Spin Blur function works flawlessly! The alt/drag works fine and a double-click does nothing.

Image 2. The MBP, this is what I get when starting the Spin Blur. The alt/drag does nothing and a double-click, well the 3rd image shows what happens with a double-click.

Image 3. The alt/drag does work, but it moves the entire ellipse and not just the bullseye. A double-click create a semi-bullseye (one white circle) in the center of the ellipse. The image shows the ellipse after the double-click. When I try and move with a alt/cmd it will move the main bullseye like it's supposed to, but it also moves the entire ellipse. It does not move the bullseye separate from the ellipse.

IamSam, thanks for the video link, but she only only elaborated on the normal function and not on any possible settings. I don't see any place where settings are available for this filter function. I'm getting frustrated since I want to use the MBP and not always the iMac.

Thanks again to you both. - John

Image 1.
Spin iMac SS.png

Image 2.

Image 3.
Spin MBP2 SS.png
No worries.

From what you've described I don't think this can be called a PS issue...if it works ok on one machine and not another then it suggests its more a hardware / OS issue or a corrupt install.

I'm not an apple user but there are people on PSG that are, IamSam being one.

Thanks MrToM! I'm beginning to think the same thing. The problem is, I don't know where to start. Maybe someone with with Macs will have a suggestion.

The usual response to this type of problem is to reset the preferences file.

If you've not done this already its worth a go but I recommend you save a copy of the preferences FIRST so if it doesn't solve your problem you can revert back to how it is now.

There are plenty of posts here at least on how to reset the preferences.

Good luck.

Sorry to double post but I didn't want you to miss this with just a post edit...

How to reset your preferences:
1. CLOSE photoshop.
2. Navigate to the settings folder...(I think this is right...adjust if it is not.)

Users/ [user name] /Library/Preferences/Adobe Photoshop [???] Settings

3. RENAME the settings folder...to something like Adobe Photoshop [???] Settings.OLD
4. Restart Photoshop.

PS will create a brand new settings folder.
Try the Spin blur to see if its Ok or not.

If not:
CLOSE Photoshop.
Delete the new 'settings' folder.
REVERT your original 'settings' folder to its former name. (Or better still, make a copy and rename that)
Restart Photoshop.
Your settings should be restored.
Try something else to fix the problem.

If OK:
You have two choices...

A. Stick with the new settings folder and redo all your preferences...could be the simplest way if your preference changes are minimal.

B. Go back to your OLD settings and track down what the problem was...it could be an extension or plug-in or just a corrupt pref somewhere.

Cant suggest much more than that I'm afraid.

I reset preferences and that solved my problem! Thanks to you both. I still have a problem when I do a quick mask overlay. The red color is very transparent and I don't know how to increase it's opacity. Here's an image showing what I mean and a 2nd showing the results of my motion. I still have a lot to do on the image, but I'm making progress thanks to you guys.
Screen Shot 2016-08-29 at 12.28.26 PM.png

...I reset preferences and that solved my problem! Thanks to you both...
No worries.

Just in case its not obvious you can change the colour of the 'Quick Mask' too by clicking that large colour swatch in the Quick Mask Options....it may be handy if you are trying to mask something of the same colour. :thumbsup:

That car is now going very fast with no driver!!!!!

Sent from my iPhone using Tapatalk
Thanks wayn0i! :) That's our son's car and he is very proud of it. We took some shots Saturday and I'm trying to learn some new PS techniques. It's sure fun for an old man!