What's new

Patch Tool Problem


limey

Well-Known Member
Messages
195
Likes
3
Hi, I've used the Patch Tool many times in the past but for some reason I can't get it to work right this time.
I'm selecting the area that I want to extend and dragging it to it's destination but it does't seem to cover the new area completely. It seems to have a transparency effect to it, the object I am covering with the patch is still showing through faintly.
It is probably something very simple that I am overlooking but it's got me stumped.
I'm using PS CS5 on a mac.
 

IamSam

Administrator
Staff member
Administrator
Messages
17,246
Likes
11,029
Have you tried resetting the tool or resetting Ps preferences?
 

limey

Well-Known Member
Messages
195
Likes
3
Hi Sam, thanks for the suggestion. However I'm not sure how I would go about resetting the tool or preferences could you tell me how to do that?
 

IamSam

Administrator
Staff member
Administrator
Messages
17,246
Likes
11,029
Sure.

This is how to reset your preferences in Photoshop: Press-and-hold Command-Option-Shift on a Mac or Ctrl-Alt-Shift on a PC, while you start Photoshop. As you start the program you will get a pop-up dialog asking you if you would like to delete the settings file. Deleting the file will create a new set of preferences from scratch.

To reset a tool.
Go to the TOOL PRESET PICKER located in the top left had corner of the TOOL OPTIONS BAR.
Right click and choose RESET TOOL.
or
Click on the down arrow and a window will open.
On the top right hand side of that widow will be a gear icon…click on this and choose RESET TOOL.
 

limey

Well-Known Member
Messages
195
Likes
3
Well Sam, no change to the patch tool problem. I reset the Preferences and also reset the Patch tool. I did lose a bunch of photos I was working on that had been in my Open Recent setting, wish I'd know that was going to happen.
However on the bright side I now know how to reset the Prefs, and Tools, Thanks.
 

IamSam

Administrator
Staff member
Administrator
Messages
17,246
Likes
11,029
limey said:
Well Sam, no change to the patch tool problem. I reset the Preferences and also reset the Patch tool.
Great.

limey said:
I did lose a bunch of photos I was working on that had been in my Open Recent setting, wish I'd know that was going to happen.
Well, you really didn't lose the photos, they are still where you saved them. You just lost the listing from the 'open recent' menu. They will re-appear when you reopen the files again.

Based on your description, I made the assumption that the tool was not functioning properly and that seems to not be the case. Is there any way you can post screen shots of the the tools options bar as well as what the tool is doing wrong?
 

limey

Well-Known Member
Messages
195
Likes
3
Hi Sam, I know I didn't lose the photos completely will just have to try to remember where I put them, with my memory that could be a chore lol.

I'll try to add an image, it's been awhile since I've done that. I will try to show the patch tool results just before de-selecting.
Let me know if there is anything else you want to see.

I did notice something that I hadn't seen before but not sure if it would have any effect or not.
It is 'Use Pattern' in the tool option's bar and it becomes active as soon as the Patch selection is made. It doesn't look like there is any way to turn it off so I'm not sure what it's purpose is. I tried using one of the darker choices but it didn't make any difference to the results.

Screen Shot 2017-02-06 at 9.35.35 AM.jpg
 

Tom Mann

Guru
Messages
7,223
Likes
4,339
Hi Limey -

I don't think there is anything at all wrong with your patch tool. It is well known for having difficulties dealing with sharp edges, especially of highly contrasting colors and textures, e.g.,
http://www.earthboundlight.com/phototips/patch-near-the-edges.html
http://graphicdesign.stackexchange.com/questions/34976/photoshop-how-to-stop-patch-tool-from-smudging-nearby-pixels-as-last-step-q

And to demonstrate the above comments, below is the same effect on my machine. I simulated a similar scene to what you were dealing with:

2017-02-06_133258patch_tool_at_edge.jpg

It does work fine at edges / transitions that are more similar in color, tone and texture, e.g.,

2017-02-06_133432patch_tool_at_easier_edge.jpg

I'm not sure exactly what you hoped to accomplish, but if you describe what you want to do, I suspect we can help by offering alternatives.

Cheers,

Tom M
 

limey

Well-Known Member
Messages
195
Likes
3
Sorry Tom, I thought I'd replied to your last post but I don't see it so thank you belatedly for your help and patience. Glad to know it's not my Photoshop or computer that's messing up. I did accomplish what I wanted using the Clone tool.
 

Tom Mann

Guru
Messages
7,223
Likes
4,339
Glad you got it sorted out, LImey. Don't hesitate to stop by again if something weird happens again, or just if you want to chat, LOL.

Cheers,

Tom M
 

Top