What's new
Photoshop Gurus Forum

Welcome to Photoshop Gurus forum. Register a free account today to become a member! It's completely free. Once signed in, you'll enjoy an ad-free experience and be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

Dodge and Burn tool Issues/Problems


Former Member
Just noticed when using the tools if i click to start the painting action using say the dodge tool and i am making a sweeping arc motion and release the click at the end of arc i only get a point to point response, the arc does not compute.

Anyone know how to correct this please?
Last edited:
Just bumping guys, it is still an issue.

Been trying to recreate your problem but it arcs for me no matter what I wreck in the settings..... unless I'm missing something.

Did you try resetting all the tools or PS preference?
Yes Vee mate, first thing i did, all other tools work normally just those two and sometimes the scrubby zoom will not zoom on images?
I've been trying to replicate this since you first posted but failed miserably.

The only thing I can think of is the speed at which you draw the arc....is your system 'quick enough' to capture the fact you are drawing an arc?

What may be happening is the system not being quick enough to actually 'see' the points between the start and end of the stroke....thus it only has a start and an end so only calculates between those two points....possibly.

Do you have anything running in the background may have priority when it comes to processor time?

Windows 7 does have issues with tablet services....have you disabled those? (Regardless of whether you use a tablet or not ..... the services are for a 'tablet' device rather than a real, proper, gfx tablet but because MS think everyone will be using a 'tablet' device the services are automatically started and can, and do, really screw it up for those of us that need to use an OS in a more 'professional' capacity instead of staring at 'kitty pictures' all day.

Did that turn into a rant? :biglaff:

Anyway....check out the services and see if anything 'tablet' related is running...especially this puppy...


No guarantees....and you've probably done this already but still...


PS....not only has vee beat me by minutes but starts with virtually the same opening line!!!!
Sheeeeshhhhh!!! If its not one......:biglaff:
Thanks Tom yeah alls ok in that department mate, and Vee i just retried the Wacom and it is k now, but when i tried with the mouse and made click hold make move to create burn under eye it did the point to point again?
Also guys i am using windows ten now if that helps?
Mouse is working great does what i request, just not playing the game within PS and those tools.
I got to run guys thanks so far, airport run for the daughter.
I don't seem to be able to replicate the problem and since I'm on mac, I'm of no help.

It's beside the point, but I'm not a fan of the Dodge and Burn Tools anyway, there are much better and more accurate ways to D&B. Using the mask on a Curves Adjustment layer is one way and it's non destructive. However, if the same problem is happening to your Brush Tool when using the mouse, then it would not help the situation.
Been playing around with this and still cannot replicate the exact problem....but...

...I do have other issues with marquee selections and the 'Direct Section' tool, and in 2015 there are still major display issues with the 'Crop' tool and selection tools in general.

The common denominator here being Win10.

I just don't think Win10 is 'Stable' enough yet to rule it out as the cause of many issues with installed software. The 'Upgrade' to Win10 has a major fault in deleting random existing files during the installation process so its more than likely that this could cause problems.

From a quick glance around the net the more popular software titles do all seem to have issues with the Win10 "upgrade".....the solution in most cases is to start over with a clean install.....yeah, right, thanks MS.

I'd try re-installing or at least 'repairing' the CS5 installation and see if that restores it, otherwise I'd ditch Win10 and revert back to Win7...or whatever you used before.

You could also try the 'Compatibility' option for CS5 although I've never known this to actually do anything when I've tried in the past....not even when run 'As Administrator'.

I think you may have to accept that Win10 and CS5, (or any version really), just isn't going to work as it should in Win10....not for a few years anyway.

None of the software I have ran 100% in Win10 so for me its already history.

Sorry that's not much help but the more I hear about software not running on Win10 the more I believe its solely Win10 to blame, and although there seems to be common problems the solutions are probably only good on a machine-to-machine basis.

Yeah MrTom, i had come to the same conclusion as you regarding W10 but funny things do happen mate.
It is working normally today well this afternoon, i ran CC Cleaner and it works fine now.
Not saying that was the answer but it is working normally this afternoon?

Thanks for the help and the info buddy.
"I think you may have to accept that Win10 and CS5, (or any version really), just isn't going to work as it should in Win10....not for a few years anyway"

I don't think that is really true, I installed Windows 10 through the upgrade path and don't have any issue with Photoshop CS6 and CC2015 and I've been using it since launch Windows 10 that is, both version are running perfectly on my PC all tools work as they should as well as everything else , as well as that I have Photoshop CS6 on my Laptop with Windows 10 also installed through the upgrade path and that's running fine too.
As well as that I don't have any issues with any applications that I run on both my PC and Laptop, maybe I was just one on the lucky ones, I upgraded both from Windows 8.1 although I must admit I create an image of my hard drive on a regular basis and keep my systems clean and running perfectly so maybe that helped in my case!
Just my Sunday rant, over now :)