What's new

Hidden Channels


Mrnicoo

New Member
Messages
1
Likes
0
I suddenly foot problem with that the layers get non-editable. I have to double click on them and then that one I clicked on get editable, but if I leave it and edit another and then go back I have to do same same.... I get this message if I try to edit any layer:
"Could not use the type tool because the target channel is hidden"

Any idea how I get rid of this ones and for all?
 

IamSam

Administrator
Staff member
Administrator
Messages
19,581
Likes
12,054
Hello and welcome to PSG.

Try hitting th Q key on your keyboard one time............then try the Type Tool again.
 

MrToM

Guru
Messages
3,504
Likes
3,227
Interesting.

I hadn't seen this problem before so had a look around to see if it was a known issue.....apparently it is...or at least it was.

An update to CC had a bug whereby 'Quick Mask' mode would be automatically selected.
This meant that anything you did on that layer was editing the 'Quick Mask' instead of the pixels.

Changing which layer you worked on turned off the 'Quick Mask' channels visibilty, but kept 'Quick Mask' active.
Switching back to the original layer meant you were still editing the 'mask' but would throw that error because its visibility is now turned off.

From what I can gather this was addressed in the next update to CC.

If the OP is still having this issue I suggest you update your PS version and see if that fixes it permanently.

If not then you'll just have to keep an eye on the 'Quick Mask' mode button and, as Sam has already mentioned, turn it off if necessary.

Regards.
MrTom.
 

IamSam

Administrator
Staff member
Administrator
Messages
19,581
Likes
12,054
Thanks MrT, I was waiting on the explanation until I knew if it was going to work or not! LOL!!
 
Last edited:

MrToM

Guru
Messages
3,504
Likes
3,227
Sorry Sam....didn't mean to steal your thunder. :redface:

Regards.
MrTooQuickForHisOwnGoodSometimes
 

IamSam

Administrator
Staff member
Administrator
Messages
19,581
Likes
12,054
LOL! I'm not bothered at all..........I do this all the time! It's my own fault, so no worries!
 

Top