Wacky Pen tool behavior

#1

Hello, all-
I'm on an iMac late '12 running Sierra (10.12.4) using PS CC 2017.1.1 and I'm having a problem I've never seen before with PS. I need to make clipping paths for the images delivered to a client. What happens is when I'm using the Pen tool and while creating the path, the Pick a Filter Type toolbar in the Layers palette randomly turns on and off especially when I am creating a bezier and Option-click on the anchor point to remove the leading handle. I end up having to click twice on the anchor point to remove the handle and I notice the Filter Type toolbar also switches between Kind and Selected. It really is annoying and slows me down.
It seems to have just started with CC '17. I have restarted PS, restarted my Mac, updated CC to latest version, reset Tools, sacrificed a rooster, etc., but nothing has helped. I haven't reset Prefs yet as I have a lot of changes to it and will do that if nothing else helps.
TIA.

 

gedstar

Forum Moderator
Staff member
Forum Moderator
#2
Hi and welcome to the forum

Can you post a full screenshot of PS with the layers panel as well
 

gedstar

Forum Moderator
Staff member
Forum Moderator
#5
Cheers

Can't see anything that you're doing wrong, the only thing I can think of is to try resetting the PS preferences.
Unless someone else can throw some light on it.
 
#6
I cannot replicate the problem so it looks like resetting the prefs is the next step.....or another rooster gets it.

BEFORE you go resetting anything BACKUP your prefs folder FIRST.
This way if it isn't a solution to the problem you can revert back....nothing lost.

Unless the problem can be replicated it will be very difficult to track down what it is.

Regards.
MrToM.
 
#7
So it appears to be on my end. Well, it's really annoying... Oh, and one other issue, if this helps, is sometimes-sometimes!-when I make a Path and turn it to a selection, the Path on the inside of a loop of wire, e.g., doesn't become selected! No marching ants. I'm still working that out too... I'll just go back to CS5 until something gets solved.
Thx again for the help!
 
#10
Looks like resetting Preferences did the trick. Twenty-five years on PS and I have never had to do this. Probably some kind of ransomware or disruption in The Force must have caused it!
Seriously, thx for the help and I'll report back if anything changes.
 
#11
Looks like resetting Preferences did the trick. Twenty-five years on PS and I have never had to do this. Probably some kind of ransomware or disruption in The Force must have caused it!
Seriously, thx for the help and I'll report back if anything changes.
Well, it's doing it again. It's gone back to that behavior that when I have a Path inside another Path, it doesn't become selected. I'm going to contact Adobe as I'm creating Clipping Paths all the time and since I'm paying for 2017 CC and can't use it... I did download the latest update to PS CC but I still have this issue.
 
#13